debian

Broken packages galore after installing Python 3.6 from source  #angularjs #reactjs

  • Stack Overflow works best with JavaScript enabled
  • Browse other questions tagged python-3.x debian python-3.6 or ask your own question .
  • The following information may help to resolve the situation: The following packages have unmet dependencies: python-pil : Depends: python (< 2.8) but 3.6.0-1 is to be installed Depends: python:any (>= 2.7.5-5~) E: Unable to correct problems, you have held broken packages.
  • sign up log in tour help
  • This may mean that you have requested an impossible situation or if you are using the unstable distribution that some required packages have not been created or been moved out of Incoming.

I don’t know exactly what I did, but now I have broken packages, and debian wants me to uninstall the Cinnamon WM, in addition to a bunch of other libraries. I built Python 3.6 from source and installed. Now when I try to install something I always get this:

@ng_real_ninja: Broken packages galore after installing Python 3.6 from source #angularjs #reactjs

I don’t know exactly what I did, but now I have broken packages, and debian wants me to uninstall the Cinnamon WM, in addition to a bunch of other libraries. I built Python 3.6 from source and installed. Now when I try to install something I always get this:

The following packages were automatically installed and are no longer required: apache2-bin apg cinnamon-control-center-data cinnamon-l10n cinnamon-screensaver cjs cracklib-runtime cups-pk-helper diffstat dleyna-server docutils-common docutils-doc gdebi-core gir1.2-accountsservice-1.0 gir1.2-caribou-1.0 gir1.2-cinnamondesktop-3.0 gir1.2-cmenu-3.0 gir1.2-gconf-2.0 gir1.2-gdesktopenums-3.0 gir1.2-gkbd-3.0 gir1.2-gnomebluetooth-1.0 gir1.2-gnomedesktop-3.0 gir1.2-gnomekeyring-1.0 gir1.2-gtk-2.0 gir1.2-javascriptcoregtk-4.0 gir1.2-keybinder-3.0 gir1.2-meta-muffin-0.0 gir1.2-networkmanager-1.0 gir1.2-nmgtk-1.0 gir1.2-notify-0.7 gir1.2-packagekitglib-1.0 gir1.2-polkit-1.0 gir1.2-rb-3.0 gir1.2-secret-1 gir1.2-totem-1.0 gir1.2-totem-plparser-1.0 gir1.2-upowerglib-1.0 gir1.2-vte-2.90 gir1.2-webkit2-4.0 gir1.2-xkl-1.0 gkbd-capplet gnome-bluetooth gnome-control-center-data gnome-online-accounts gnome-session-bin gnome-settings-daemon gnome-user-share grilo-plugins-0.2 gstreamer0.10-nice gstreamer0.10-x guile-2.0-libs hardening-includes libapache2-mod-dnssd libapr1 libaprutil1 libaprutil1-dbd-sqlite3 libaprutil1-ldap libapt-pkg-perl libarchive-zip-perl libart-2.0-2 libart-2.0-dev libavahi-client-dev libavahi-common-dev libbabl-0.1-0 libbonoboui2-common libbs2b0 libc-ares-dev libc-ares2 libcairo-script-interpreter2 libcanberra-dev libcaribou-common libcaribou0 libcinnamon-control-center1 libcinnamon-desktop4 libcinnamon-menu-3-0 libcjs0 libclone-perl libcolord-gtk1 libcrack2 libdbus-1-dev libdleyna-connector-dbus-1.0-1 libdleyna-core-1.0-3 libdmapsharing-3.0-2 libelfg0 libemail-valid-perl libgadu3 libgconf2-doc libgdata-common libgdata19 libgegl-0.2-0 libgeocode-glib0 libglib2.0-bin libgnome-bluetooth13 libgnomecanvas2-0 libgnomecanvas2-common libgnomekbd-common libgnomekbd8 libgnomeui-common libgnutls28-dev libgnutlsxx28 libgoa-1.0-0b libgoa-1.0-common libgoa-backend-1.0-1 libgpod-common libgpod4 libgrilo-0.2-1 libgssdp-1.0-3 libgtkspell0 libgupnp-1.0-4 libgupnp-av-1.0-2 libgupnp-dlna-2.0-3 libgupnp-igd-1.0-4 libgweather-3-6 libgweather-common libharfbuzz-dev libharfbuzz-gobject0 libibus-1.0-5 libidl0 libimage-magick-perl libimage-magick-q16-perl libio-pty-perl libipc-run-perl libjavascriptcoregtk-4.0-18 libjavascriptcoregtk-4.0-dev libjs-node-uuid libkeybinder-3.0-0 libldb1 liblist-moreutils-perl libmeanwhile1 libminiupnpc10 libmozjs185-1.0 libnatpmp1 libnemo-extension1 libnet-dns-perl libnet-domain-tld-perl libnet-ip-perl libnice10 libnss-myhostname libntdb1 liboauth0 libopenraw1 liborbit2 libp11-kit-dev libpackagekit-glib2-18 libperl5.20 libperlio-gzip-perl libpixman-1-dev libpopt-dev libprotobuf-c1 libpwquality-common libpwquality1 libpython-dev libpython-stdlib libpython2.7-dev librygel-core-2.4-2 librygel-renderer-2.4-2 librygel-server-2.4-2 libselinux1-dev libsepol1-dev libsexy2 libsgutils2-2 libssl-dev libssl-doc libtalloc2 libtasn1-6-dev libtasn1-doc libtevent0 libtext-levenshtein-perl libtidy-0.99-0 libtotem0 libv8-3.14-dev libv8-3.14.5 libwacom-common libwacom2 libwayland-dev libwbclient0 libwebkit2gtk-4.0-37 libxcb-shm0-dev libxcomposite-dev libxcursor-dev libxkbcommon-dev libxml2-dev libxtst-dev libzephyr4 lintian minissdpd mousetweaks nettle-dev node-abbrev node-ansi node-ansi-color-table node-archy node-async node-block-stream node-combined-stream node-cookie-jar node-delayed-stream node-forever-agent node-form-data node-fstream node-fstream-ignore node-github-url-from-git node-glob node-graceful-fs node-inherits node-ini node-json-stringify-safe node-lockfile node-lru-cache node-mime node-minimatch node-mkdirp node-mute-stream node-node-uuid node-nopt node-normalize-package-data node-npmlog node-once node-osenv node-qs node-read node-read-package-json node-request node-retry node-rimraf node-semver node-sha node-sigmund node-slide node-tar node-tunnel-agent node-underscore node-which nodejs nodejs-dev orbit2 packagekit packagekit-tools patchutils perlmagick pidgin-data python-apt-common python-dbus-dev python2.7-dev python3-apt python3-debian python3-mako python3-markupsafe realmd rygel sphinx-doc totem-common transmission-common x11proto-composite-dev x11proto-record-dev xwayland Use ‘apt-get autoremove’ to remove them.

, I get this:

Reading package lists… Done Building dependency tree Reading state information… Done Some packages could not be installed. This may mean that you have requested an impossible situation or if you are using the unstable distribution that some required packages have not yet been created or been moved out of Incoming. The following information may help to resolve the situation: The following packages have unmet dependencies: python-pil : Depends: python (< 2.8) but 3.6.0-1 is to be installed Depends: python:any (>= 2.7.5-5~) E: Unable to correct problems, you have held broken packages.

because I don’t want to start up my laptop to a terminal with nothing installed, having to start over (if that’s the case I may as well just re-install Debian from the ISO). Is there anything I can do?

Let me know if you may need any other command output, I’ll post it promptly.

debian

You might also like More from author

Comments are closed, but trackbacks and pingbacks are open.